Wenn Sie die INDEX Funktion mit der VERGLEICH Funktion verbinden, können Sie nicht nur nach rechts wie beim SVERWEIS suchen, sondern auch nach links. D.h. der Schlüssel kann beispielsweise in Spalte D stehen und wir suchen den dazugehörigen Werte in Spalte A. In diesem Artikel zeigen wir Ihnen wie dies in Google Sheets funktioniert.

Wenn wir die Index- und Vergleich-Formel in einer Google-Tabelle kombinieren, kann sie den Nachschlagewert unabhängig davon zurückgeben, wo sich der Wert befindet.

Google Sheets INDEX Funktion

Die INDEX-Funktion gibt einen Wert oder den Bezug auf einen Wert aus einer Tabelle zurück.

Syntax

=INDEX(Referenz, [Zeile], [Spalte])

  • Referenz – Der Zellbereich, aus dem die Werte zurückgegeben werden.
  • Zeile – [OPTIONAL – standardmässig 0] – Der Index der Zeile, die innerhalb des Referenzbereichs der Zellen zurückgegeben werden soll.
  • Spalte – [OPTIONAL – Standardmässig 0] – Der Index der Spalte, die innerhalb des Referenzbereichs der Zellen zurückgegeben werden soll.

Beispiel

=INDEX(A2:C21, 2, 3)

Google Sheets VERGLEICH-Formel

Gibt die relative Position eines Elements in einem Bereich zurück, der einem angegebenen Wert entspricht.

Syntax

VERGLEICH(Schlüssel, Bereich, [typ])

  • Schlüssel – Der Wert, nach dem gesucht werden soll. Zum Beispiel 42, „Katzen“ oder I24.
  • B- Das zu durchsuchende eindimensionale Array.
  • typ – [ OPTIONAL – Standardmässig 1 ] – Die Art und Weise, in der gesucht wird.
    • 1, der Standardwert, geht davon aus, dass der Bereich in aufsteigender Reihenfolge sortiert ist, und gibt den grössten Wert zurück, der kleiner oder gleich dem Schlüssel ist.
    • 0 zeigt eine genaue Übereinstimmung an und ist in Situationen erforderlich, in denen der Bereich nicht sortiert ist.
    • -1 setzt voraus, dass der Bereich in absteigender Reihenfolge sortiert ist, und den kleinsten Wert grösser oder gleich dem Schlüssel zurückgibt.

Beispiel

=VERGLEICH(“Gretta”, A2:A21, 0)

Kombination von Index und Vergleich

INDEX und VERGLEICH können zusammen verwendet werden, um erweiterte und dynamischere Lookups durchzuführen.

Beispiel-Tabelle

Ziel

Geben wir die E-Mail-Adresse von „Gretta“ mithilfe von Index und Vergleich via Vorname zurück

Formel

=INDEX(A2:C21, VERGLEICH(„Gretta“, A2:A21, 0), 3)

 

Die Werte rückwerts finden.

Ziel

Geben wir den Vornamen von „Kerrie“ mithilfe von Index und Match über E-Mail-Felder zurück

Formel

=INDEX(A2:C21, Vergleich(„kdiehn8@vimeo.com“, C2:C21, 0), 1)

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.