Mit der INDIREKT-Formel können wir Formeln mit eigenen Parameter erstellen. Wenn Sie in Excel eine Formel eingeben wie bspw. =“A“&1, dann gibt Excel den Text „A1“ zurück. Wenn Sie stattdessen auf die Zelle A1 verweisen möchten, müssen Sie die Formel INDIREKT verwenden.

Wir haben ein Datensatz mit Einkäufen, auf die ein Rabatt angewendet werden muss. Die Höhe des Rabatts wird durch die Artikelgruppe bestimmt: A, B oder C. Die Nachschlagetabellen für jede Kategorie befinden sich auf verschiedenen Blättern, wie unten dargestellt.

Damit zu einem späteren Zeitpunkt auch weitere Tabellenblätter hinzugefügt werden können, bauen wir die Formel dynamisch auf. Wir verwenden hierfür die SVERWEIS-Formel in Kombination mit der Formel INDIREKT, um auf das entsprechende Arbeitsblatt zu verweisen.

Beginnen wir mit der Syntax, die Excel verwendet, um auf Zellen in einem anderen Arbeitsblatt zu verweisen. Vor dem Namen des Arbeitsblatts steht ein Hochkomma, gefolgt von einem Hochkomma und einem Ausrufezeichen.

Beispiel
=’Gruppe A‘!A2:B7

Wenn nun der Buchstabe „A“ in Zelle B2 steht und Sie darauf veweisen möchten, dann können Sie die Formel wie folgt aufbauen (Siehe Beispiel unten). Wenn Sie nun den Wert in B2 verändern bspw. auf „B“, dann verweist die Formel automatisch auf das Blatt „Gruppe B“.

Beispiel
=INDIREKT(„‚Gruppe “ & B2 & „‚!A2:B7“)

Diese Formel resp. dieser Verweis können wir nun auch für die SVERWEIS-Formel verwenden. In dieser Formel Suchen wir den Wert D2 im korrekten Registerblatt.

Formel
=SVERWEIS(D2;INDIREKT(„‚Gruppe “ & B2 & „‚!A2:B7“);2)

Und hier sind die Ergebnisse…

Der Rabatt wird dann wie folgt berechnet:

Formel
=C2 * D2 * (1-F2)

Das Ergebnis sieht so aus.

Weitere Informationen zum SVERWEIS finden Sie hier und eine Anleitung zur Index-Vergleich-Formel hier.

Haben Sie ein Problem mit Ihrer Excel-Datei? Für nur 49 Fr. analysieren wir Ihre Datei und erstellen einen konkreten Vorschlag. Weitere Infos dazu auf: www.exact-construct.ch 

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.