Wenn Sie SVERWEIS oder INDEX/VERGLEICH verwendet haben, bin ich sicher, dass Sie die Flexibilität lieben werden, die die XVERWEIS – und XVERGLEICH -Funktion bietet.

In diesem Artikel zeigen wir, wie Sie die Funktionen XVERWEIS und XVERGLEICH in Excel kombinieren, um den Wert aus Zeile und Spalte dynamisch nachzuschlagen. Wenn Ihre Excel-Version XVERWEIS und XVERGLEICH nicht unterstützt, können Sie stattdessen Mehrere Kriterien für eine INDEX-VERGLEICH-Formel lesen.

Beispiel XVERWEIS mit XVERGLEICH

Die Formel lautet:

=XVERWEIS(Zeilenkriterien;$B$3:$B$12;INDIREKT(ADRESSE(Zeilenanfang;XVERGLEICH(SpalteKriterien;A2:F2;0;1))&“:“&ADRESSE(Zeilenende;XVERGLEICH(SpalteKriterien;A2:F2;0;1)));“Nicht gefunden“;0;1)

Die obige Formel verwendet XVERWEIS, INDIREKT, ADRESSE und XVERGLEICH.

Wir verwenden XVERWEIS, um nach der Zeile zu suchen. Und wir verwenden INDIREKT, ADRESSE und XVERGLEICH, um nach der Spalte zu suchen.

Wie funktioniert der XVERWEIS

Lassen Sie uns über die Formel sprechen, die nach Zeilen sucht.

Formel:

=XVERWEIS(Zeilenkriterien;$B$3:$B$12;F3:F12;“Nicht gefunden“;0;1)

Wir ersetzen die Zeilenkriterien durch “Blake“

=XVERWEIS(“Blake“;$B$3:$B$12;F3:F12;“Nicht gefunden“;0;1)

Der Wert 1’125 wird zurückgegeben.

Das Ersetzen von Zeilenkriterien durch den Vornamen gibt sein Gehalt zurück.

Aber das Problem ist, dass die Spalte nicht dynamisch ist.

Wie funktioniert der XVERGLEICH

Lassen Sie uns über die Formel sprechen, die nach einer Spalte sucht.

Formel:

=INDIREKT(ADRESSE(Zeilenanfang;XVERGLEICH(SpalteKriterien;A2:F2;0;1))&“:“&ADRESSE(Zeilenende;XVERGLEICH(SpalteKriterien;A2:F2;0;1)))

Durch Ersetzen von SpalteKriterien wird der Wert dynamisch zurückgegeben.

Wir ersetzen SpalteKriterien durch “Gehalt “, Zeilenanfang durch 3, Zeilenende durch 12.

=INDIREKT(ADRESSE(3;XVERGLEICH(“Gehalt“;A2:F2;0;1))&“:“&ADRESSE(12;XVERGLEICH(“Gehalt“;A2:F2;0;1)))

Nun gibt diese Formel die Gehaltsspanne zurück, die F3:F12 ist, wenn Sie das Gehalt durch die Spalte Alter ersetzen, gibt sie die Altersspanne zurück. Mit dieser Formel geben wir dynamisch den Wert aus der dynamischen Spalte zurück.

XVERGLEICH und XVERWEIS kombinieren

Die Kombinationsformel lautet nun:”

=XVERWEIS(”Blake”;$B$3:$B$12;INDIREKT(ADRESSE(3;XVERGLEICH(“Gehalt“;A2:F2;0;1))&“:“&ADRESSE(12;XVERGLEICH(“Gehalt“;A2:F2;0;1)));“Nicht gefunden“;0;1)

Hier ist die Beispiel-Datei zum downloaden: Suchen Sie mehrere Kriterienzeilen und -spalten über XVERWEIS und XVERGLEICH

Benötigen Sie Excel-Hilfe?

Brauchen Sie Unterstützung in Excel oder einen Programmierer für Makros. Kontaktieren Sie uns entweder via Kontaktformular https://www.exact-construct.ch oder 052 511 05 25.

3 Replies to “Mehrere Kriterien mit XVERWEIS und XVERGLEICH

  1. Hallo, ich suche ein Beispiel für den Mehrwert von XVerweis und XVergleich.
    Die Lösungen für dieses Beispiel kann ich auch mit den Kombinationen SVerweis und Vergleich oder Index und Vergleich lösen.

    1. Im Gegensatz zum SVERWEIS kann mit der Funktion XVERWEIS den Suchbegriff in jeder Spalte der Tabelle gesucht werden. Beim SVERWEIS wird nur die erste Spalte einer Tabelle durchsucht. Eigentlich kannst du mit dem XVERWEIS die komplizierte INDEX-VERGLEICH-Formel vergessen, weil du es auch mit dem XVERWEIS lösen kannst.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.