Bei der Verwendung der Funktion MITTELWERT in Excel muss man wissen, dass auch Nullwerte miteinbezogen werden. Inbesondere bei grossen Datensätzen, welche mittels Formeln berechnet wurden, können NULLER vorhanden sein. Beispielsweise wenn die Formel auf eine leere Zelle verweist. Üblicherweise macht es in so einem Szenario keinen Sinn, dass die NULLER in die MITTELWERT-Berechnung mit einbezogen werden.

Wie werden NULLER bei der MITTELWERT-Berechnung ignoriert

Die Funktion MITTELWERTWENN gibt einen Mittelwert in Abhängigkeit von einer Bedingung zurück, wobei die folgende Syntax verwendet wird:

MITTELWERTWENN([bereich], [kriterien])

[bereich]: Der Bereich der Zellen, für die der Mittelwert berechnet werden soll, einschliesslich Zahlen, Namen, Arrays oder Bezügen, die Zahlen enthalten.

[kriterien]: Die Kriterien in Form einer Zahl, eines Ausdrucks, eines Zellbezugs oder eines Texts, mit denen definiert wird, für welche Zellen der Mittelwert berechnet werden soll.

[kriterien] ist der Ausdruck, den die referenzierten Werte erfüllen müssen. Sie verwenden das Kriterium >0, um Nullwerte auszuschliessen. Die Funktion =MITTELWERTWENN(D2:D6,“>0″) in D7 bildet den Durchschnitt der Werte in D2:D6 nur dann, wenn sie ungleich 0 sind.

In Spalte C wird die Standardfunktion MITTELWERT() verwendet, die auch Nullwerte berücksichtigt. Der Durchschnitt wird in Spalte A mit der Formel =SUMME(B2:B7)/ANZAHL(B2:B7) berechnet.

Bei der Verwendung von MITTELWERTWENN() ist zu beachten, dass leere Zellen ignoriert werden, was möglicherweise nicht erwünscht ist.


Eine alternative Formel könnte so lauten: =SUMME(Bereich)/ZÄHLENWENN(Bereich;“<>0″)
Sind Sie an weiterenen Tipps interessiert? Informationen zum SVERWEIS finden Sie hier und eine Anleitung zur Index-Vergleich-Formel hier.

Haben Sie ein Problem mit Ihrer Excel-Datei? Für nur 49 Fr. analysieren wir Ihre Datei und erstellen einen konkreten Vorschlag. Weitere Infos dazu auf: www.exact-construct.ch 

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.